Plugins y algunos trucos para WP

Error al actualizar plugins «Actualización de plugin fallida.»

ACTUALIZACIÓN 16-1-2016

Al parecer el servidor donde estaba alojada esta página tenia una versión de PHP inferior a la recomendada, al actualizar la versión de PHP ya no hace falta hacer nada.

SOLUCIÓN: Tener una versión de PHP actuzalizada, PHP 5.5 o superior.

————————————————-Entrada anterior———————————————-

Al actualizar a la versión 4.4 de Wordpres me ha pasado esto con un par de webs, al querer actualizar plugins no había manera.

He probado de borrar e instalar el plugin desde cero (se puede hacer con el plugin de AKISMET per ejemplo), y entonces viene el susto grande con este pedazo de error:

Descarga fallida. SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

¿Buen susto verdad?

Por suerte a mi me ha funcionado añadiendo el siguiente código en mi functions.php

<?php add_action('http_request_args', 'jkudish_http_request_args', 10, 2);
function jkudish_http_request_args($args, $url) {
$args['sslverify'] = false;
return $args;
}?>

Con esto me he ha funcionado, espero que si alguien lee esto también le solucione este «marrón».

 

 


Dejar una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Powered by WordPress | Designed by Elegant ThemesPolítica de privacidad